配信済事業者一覧ソフトウェアのブロックに何も表示されなくなり「IPv4設定」ができなくなったのを直したお話


IPv4 to IPv6

IPv6にした後に「OpenVPN」を設定するためには、配信済事業者一覧ソフトウェアの画面からIPv4の設定をしていくのですが、なぜか「IPv4設定」が表示されなくなってしまいました。


一度設定してしまえば通常この画面を開くことはないのですが、今回NASを新調したことにより旧NASから新NASへOpen VPNのサーバを変更しようと思いました。


そして静的NAPTの設定を新NASのサーバへ向けようと、「配信済事業者一覧ソフトウェア」の画面(http://ntt.setup:8888/t)を開いてみたところ・・・すべてが0ブロックとなり何も表示されません・・・


このような画面になってしまいました。


IPv4設定が無い!

通常は、この左上のところに「IPv4設定」のアイコンが表示されています。


「IPv4設定」の画面に入れないことには何もできません。
この状態でもOpenVPNは動いていますので、新サーバのIPを旧サーバのものに設定すればOpenVPN自体は動きます・・・
しかし、今後入れないのは困ることがあるかもしれないので、直せるのであれば直したいところです。



困った時は・・・まずはGoogleです。
しかしググってみてもそれらしいものはひっかかりません。
ルータ(PR-400KI)の不具合なのかもしれませんので、直らないかもしれません。



常套手段としてルータの再起動、PCの再起動を行ってみました。
残念ながら、変化ありません。



他のPCやiPhoneからアクセスしても変わらないので、ルータ側の問題なのでしょう。



このような状態でできることは、ルータの初期化です。
ひかり電話も繋がっていますし、ルータの設定など・・・昔のことなので再設定できるかわかりません。
そこで、まずはルータ設定のバックアップを行います。


ルータ設定のバックアップ

左メニューの「設定値の保存&復元」を選択したあとに、「ファイルの保存」をクリックするだけです。
これで何が起きても戻すことができる・・・はずです。



というわけで初期化します。


初期化!

「完全初期化」を行えば良いのですが・・・簡単に直ればその方が嬉しいので、まずは「部分初期化」をしてみます。
左メニューの「設定値の初期化」を選択したあとに、「電話関連以外の設定初期化」をクリックします。
自動的にルータが再起動されます。

DHCPの設定も初期化されますので、IPをうまく取れない場合は、パソコンの方のネットワークの設定等から再度IPを取得し直しみてください。


ルータの管理画面へのログインは今までのIDとパスワードで入れました。
早速基本設定を見てみます・・・
初期化されたためか「接続先設定(IPv4 PPPoE)」がグレーアウトせずに設定ができるようになっていました。
(通常はIPv6にした時にグレーアウトして設定を変更できなくなります。)


「接続先設定(IPv4 PPPoE)」をしようかとも思ったのですが、面倒なので、バックアップした設定を戻したらどうなるのか試してみました。


先ほどのバックアップ画面から、「ファイルを選択」後、「復元実行」をクリックするだけで設定を戻すことができます。
パスワードが入っていない場合は、ログインパスワードを入れましょう。


復元!

自動的に再起動されます。



起動後、管理画面へログインし基本設定を見てみます。
問題無く元の設定に戻っています。
IPv4の設定もいじれます・・・(良いのかな・・・)



それでは・・・「配信済事業者一覧ソフトウェア」の画面を開いてみます。



やっぱり・・・ありません。



と思ったのですが、ブラウザのキャッシュをクリアしてみたら・・・

無事に「IPv4設定」が戻ってきました。


通常の「配信済事業者一覧ソフトウェア画面

IPv4設定の中身も初期化され、こちらは設定がすべて無くなっていました。
再度OpenVPN用の設定を行い完了です。



「配信済事業者一覧ソフトウェア」の画面に表示されなくなってしまった原因は不明です。



もし0ブロックとなり「IPv4設定」が消えてしまったら試してみてください。
復活するかもしれません。



--
1日経ったら、「接続先設定(IPv4 PPPoE)」はグレーアウトして設定できなくなっていました。