TP-LINKのメッシュWi-fiルータ「Deco M9 Plus」が突然インターネットに繋がらなくなったのを直したお話


TP-Link メッシュ Wi-Fi システム トライバンド AC2200 (867 + 867 + 400) 無線LAN ルーター スマートハブ内蔵 セキュリティ搭載 2ユニット Deco M9 Plus

先日、何の前触れもなく「Deco M9 Plus」がインターネットに繋がらなくなりました。
LEDランプが赤点灯して、インターネットに繋がらない状態となってしまいました。
どのように対処したのかを備忘録的に残しておきます。


今までこのようなことは一切無く、故障知らずでした。
初めてなので、どのように復旧させれば良いのかわかりません。


「Deco M9 Plus」はシンプルなので、スマホのアプリから状況を確認するくらいしかできません。
ログ等を見ることもできません・・・
アプリの表示としては、「インターネットに接続できない」と表示されています。
他に特に・・・何もありません。


これは困りました。
が・・・このままで放っておいても繋がらないので、なんとかします。



まず、ネットワークの構成としては、「Deco M9 Plus」はブリッジ接続で利用しています。
ルータの機能は、NTTからレンタルしているルータ(PR-400KI)で行っています。

こんな感じです。

「ONU」→「PR-400KI」→「スイッチングハブ」→「Deco M9 Plus」

有線ネットワークはすべてスイッチングハブに集約しています。



そこで、まずは以下のような形で切り分けを実施しました。


  1. 有線LANも繋がらないのか
  2. 無線LANでローカルネットワークは繋がるのか

まず1つ目ですが、問題なくインターネットに出られます。
よって、PR-400KIとスイッチングハブは大丈夫そうです。


2つ目ですが、ローカルネットワークは問題なく繋がります。
インターネットのみが繋がりません。


状況から、「Deco M9 Plus」が何かしらおかしそうです。
そこで以下のような手順で復旧を試みてみました。


  1. Deco M9 Plusの再起動
  2. Deco M9 Plusのルータモードに戻してブリッジモードに戻す
  3. Deco M9 Plusとスイッチングハブを繋ぐLANケーブルの変更
  4. Deco M9 Plusのとスイッチングハブを繋いでいるポートの変更
  5. Deco M9 Plusを初期化して再設定
  6. 2階で使っているDeco M9 Plusを初期化してメインにして再設定

どれも直りませんでした・・・
本体が壊れたかと思いましたが、さすがに2台とも同じタイミングで壊れるのは考えにくいです。



こうなると、「Deco M9 Plus」が故障しているとも思えません。
そうなると、インターネットへ接続していルータが怪しくなります。
(有線LANでは問題ないけど・・・)



そこで、PR-400KIを再起動してみました。



直りました!



落雷や天気など、壊れる要素は何も無かったのですが、何かしらの要因でルータの設定がおかしくなったようです。
全てにおいて通信ができているのに・・・
なぜ「Deco M9 Plus」と「PR-400KI」の間だけダメになったのか、謎です。
ただ・・・同じような状況になったら、まずはルータを再起動してから「Deco M9 Plus」をいじった方が楽ですね。
その後は特に問題は発生していません。



在宅勤務が多いので、通信が途絶えると、とても困ります。
定期的にメンテナンスというか再起動はした方が良いかもしれないですね。



困ったら、とりあえず大元を再起動が良いのかもしれません。
使い勝手の良いメッシュWi-Fiなので、このような事があっても特に交換しようとは思いません。



ちなみに、「Deco M9 Plus」の初期化の方法はアプリからネットワークを削除すると初期化されます。
もしくは、本体裏のスイッチを長押し(LEDが消えるまで押しっぱなしですが、結構長い時間が必要)です。



これ円盤型にならないかな。。。Wi-Fi6対応Deco